Installeurs Wampserver version complète

Wampserver ne fonctionne pas avec Windows XP même SP3.
Wampserver nécessite un disque ou une partition formatée NTFS Ne fonctionne pas sur FAT32 ou exFAT

--- Installation de Wampserver ---
AVANT de procéder à l'installation de Wampserver, vous devez vous assurer que certains éléments sont installés sur votre système, sinon, Wampserver ne pourra pas fonctionner, l'installation sera défectueuse et vous devrez supprimer Wampserver AVANT d'installer les éléments qui manquaient.
Les paquetages Microsoft Visual Studio VC9, VC10 et VC11 sont impérativement requis pour Wampserver 2.4, 2.5 et 3.0 même si vous n'utilisez que des versions Apache et PHP VC11. Les paquetages Microsoft Visual Studio VC13 et VC14 sont indispensables pour Apache 2.4.17 et PHP 7
Ci-dessous, sous la rubrique --- Paquetages VC --- vous trouverez les liens de téléchargement desdits paquetages.
--- N'installez pas Wampserver PAR-DESSUS une version existante, suivez les conseils de Installer une nouvelle version de Wampserver
Si vous installez Wampserver par dessus une version existante, non seulement cela ne fonctionnera pas, mais en plus vous risquez de perdre vos bases de données existantes.
--- Installez Wampserver dans un dossier à la racine d'un disque, par exemple C:\wamp ou D:\wamp. Prenez un chemin d'installation qui ne comporte pas d'espaces ou de caractères diacritiques ; donc, pas d'installation dans c:\Program Files\ ou c:\Program Files (x86\
--- Installez Wampserver en tant qu'administrateur c'est-à-dire Clic-Droit sur le fichier exécitable puis Exécuter en tant qu'administrateur. Ceci est à effectuer pour tous les exécutables d'installation des addons, applications, outils ou paquetages VC++.
Il faut, AVANT l'installation, désactiver ou fermer certaines applications :
- Fermer Skype ou le forcer à ne pas utiliser le port 80
Item N° 04 de Wampserver CONSEILS DE DÉPANNAGE
- Désactiver IIS
Item N° 08 de Wampserver CONSEILS DE DÉPANNAGE
- Paquetages VC++
-- VC9 Packages (Visual C++ 2008 SP1)
Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)
Microsoft Visual C++ 2008 SP1 Redistributable Package (x64)
-- VC10 Packages (Visual C++ 2010 SP1)
Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
-- VC11 Packages (Visual C++ 2012 Update 4)
Les deux fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe à télécharger sont sur la même page :
Visual C++ Redistributable Visual Studio 2012 Update 4
-- VC13 Packages Update 5 (Visual C++ 2013)
Les deux fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe à télécharger sont sur la même page :
Visual C++ Redistributable Packages Visual Studio 2013
-- VC14 Packages (Visual C++ 2015) -> Remplacé par VC15 ci-dessous
-- VC15 Paquetages (VisualStudio 2017)
Visual C++ Redistributable Packages for Visual Studio 2017 x86
Visual C++ Redistributable Packages for Visual Studio 2017 x64
VC2017 (VC15) est retrocompatible avec VC 2015 (VC14). Cela signifie qu'un module VC14 peut être utilisé avec les binaires VC15. De par cette compatibilité, le numéro de version de Redistributable est 14.1x.xx et après l'installation de VC2017 (VC15), les paquetages Redistribuable VC2015 (VC14) sont supprimés mais vous pourrez toujours utiliser VC14.

Si vous avez un Windows en 64 bit, il faut installer les deux versions 32 et 64bits, même si vous n'utilisez que Wampserver 32 bit
Voir item N°20 de CONSEILS DE DÉPANNAGE
Pour vérifier si les paquetages VC requis sont correctement installés, vous pouvez utiliser le programme Vérifications paquetages VC++ installés disponible dans la section Outils de cette page et ensuite télécharger puis installer les paquetages manquants. Tous les paquetages VC++ peuvent être téléchargés depuis la section Visual C++ Redistribuable Packages de cette page.
Si vous penser ne pas être en accord avec ces prérequis, valider Annuler pour annuler l'installation, appliquer les prérequis et relancer l'installation.

------ Aprés Installation ------

--- Lancement de PhpMyAdmin
Au lancement de PhpMyAdmin, il vous sera demandé un nom utilisateur et un mot de passe.
Après installation de Wampserver 3, le nom utilisateur par défaut est "root" (Sans les guillemets) et il n'y a pas de mot de passe, ce qui veut dire que vous devez laisser la case Mot de passe du formulaire d'accès vide.
Vous aurez un message d'avertissement :
Vous êtes connecté en tant que «root » sans mot de passe, ce qui correspond à la valeur par défaut de MySQL. Votre serveur MySQL est donc ouvert aux intrusions, et vous devriez corriger ce problème de sécurité en assignant un mot de passe à l'utilisateur « root ».
Ce n'est pas un problème tant que l'accès à Phpmyadmin reste en local.
Néanmoins, certaines applications WEB ou CMS demandent que l'utilisateur MySQL ait un mot de passe. Auquel cas, il vous faudra créer un utilisateur avec mot de passe en passant par l'onglet Comptes Utilisateurs de PhpMyAdmin.

--- Utilisation des menus et sous-menus de Wampmanager
Ne pas utiliser les touches du clavier pour naviguer dans les menus et sous-menus de l'icône Wampmanager.

--- Pour toute question relative à Wampserver 3
Veuillez utiliser le forum spécifique et francophone
N'utilisez pas une discussion déjà existante, mais créez votre propre discussion via l'item : Nouvelle discussion après avoir lu LIRE et RÉPONDRE AVANT DE POSER UNE QUESTION de ce même forum
 

Mises à jour Wampserver

Addons Wampserver 3

Applications

Apache

 

PHP

MySQL

MariaDB

 

Outils

 

Visual C++ Redistribuable Packages